IT Requirements for Access

Last updated: Friday, December 30, 2016

To make full use of this site, you must meet the following IT requirements:

  • Internet Explorer 8 or above. Some NHS organisations still use much older versions of IE. Ask your IT department for an IE upgrade or switch to a different browser such as Google Chrome or Firefox, with which this portal is compatible.

  • Access to the following websites must be permitted:


If you cannot access some of this content, then please speak to your IT department in the first instance in case content is being blocked by your firewall, as they should be able to resolve this for you. If this is not effective, then please contact us.